Facebooktwittergoogle_plusredditpinterestlinkedinmail

Bom dia,

Fiz um projeto de loja virtual utilizando o nopcommerce na versão 3.7.
Baixei um plugin para integrar com o pagseguro, enquanto estava executando o projeto em localhost estava tudo funcionando corretamente, quando publiquei o projeto, na Kinghost, está dando uma mensagem de erro, segue abaixo:

Regras de segurança de herança foram violadas ao substituir membro: ‘Uol.PagSeguro.Domain.ServiceError.GetObjectData(System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)’. A acessibilidade de segurança do método de substituição deve corresponder à acessibilidade de segurança do método substituído.

Já pesquisei em vários lugares no google, mas não consegui resolver ainda. Já baixei um plugin diferente, mas também não resolveu. Peço que me ajudem.

Obrigado
Daniel

Olá Daniel,

De acordo com a mensagem de erro que você passou o problema ocorre na biblioteca do UOL. Você possui o código-fonte do plugin que esta utilizando? Que plugin você está utilizando? Em que momento o erro acontece?

Abraço,
Equipe nopCommerce Brasil

Quase 20 anos de experiência no mercado de TI.
Atuação em grandes empresas como Netshoes, Borland, JBS, Bradesco, Hospital das Clínicas, Rede, Prodam, HSPE, Instituto Ayrton Senna, e também em empresas internacionais como Delta Dental, T-Mobile, Pepsi e Mckesson.

Facebooktwittergoogle_plusredditpinterestlinkedinmail